Download

Download Youtube AdBlocker here.

Current Release

YouTube AdBlocker 1.9

Minimum requirements: You need to be using the latest version of Firefox (3.6), Firefox Mobile (1.0), Thunderbird (3.0), or Chrome.

Need Firefox?

Download Firefox 3.6 – Here is the latest version of Firefox. To use YouTube Adblocker you will need either Firefox or Chrome.

Need Chrome?

Download Chrome – If you like Google, big windows, and not a lot of buttons on your browser try Chrome.

Recent Updates to YouTube AdBlocker

  • Better at reporting users of issues and new version availability.
  • Increased support for Firefox 4.
  • We have make leaps and bounds on memory usage, and performance.

Leave a Reply